Talk:Debian Sarge on Xen

From ConShell
Jump to: navigation, search

debootstrap out of date

The currently avaialable debootstrap RPM seems to trip over several missing debian packages (such as gcc-3.2-base and libgnutls7). I worked around these by editing the /usr/lib/debootstrap/scripts/sarge and removing some (like gcc-3.2-base) or updating others to packages which are still available (such as libgnutls11).

After a couple interations of that I was able to get a base system, chroot into it, create a valid sources.list, and run apt-get -f update && apt-get -f dist-upgrade and generally get things running. (Still working on the Xen portion of this exercise; will update this page when I get that far).